SkyTab Online Processing Issues Reported

Incident Report for Shift4

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 17:58 PDT

Identified

Shift4 is aware of an issue that is affecting payment processing for customers using our SkyTab Online Ordering solution, including online ordering platforms such as DoorDash and kiosk ordering. We are working to resolve this issue as quickly as possible and sincerely apologize for the inconvenience.
Posted Jul 03, 2025 - 16:58 PDT
This incident affected: SkyTab (SkyTab POS - US).