Azure degradation of services: Shift4Shop
Incident Report for Shift4
Resolved
Shift4Shop hosting issues have been resolved
Posted Apr 21, 2022 - 06:09 PDT
Update
The latest optimization efforts allowed us to achieve stability in the hosting environment. As a result, overall performance should be at normal levels. Our team will continue to monitor the issue during the following hours closely
Posted Apr 19, 2022 - 15:51 PDT
Monitoring
The Shift4 team has worked with Microsoft in making changes to the hosting environment. We are now seeing performance improvements and will continue to monitor until we are certain the issue is fully resolved
Posted Apr 18, 2022 - 16:06 PDT
Update
We are continuing to experience intermittent performance issues within our hosting environment and working with Microsoft to diagnose and resolve the issue
Posted Apr 18, 2022 - 10:16 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2022 - 12:50 PDT
Identified
Microsoft has reported intermittent Azure service issues due to a failing hard drive in the Azure hosting environment. This issue is impacting three clusters in the Azure East region where a number of Shift4Shop sites are hosted. Microsoft is actively working to replace the failing hard drive and live-migrate Shift4Shop VMs. An ETA for hardware replacement and migration has not been provided by Microsoft. The Shift4Shop team is in contact with Microsoft and will provide an update as soon as an ETA is provided.
Posted Apr 16, 2022 - 12:49 PDT
This incident affected: Shift4Shop (Online Stores, API, Support Systems).