NICE Outage 3/23/25

Incident Report for Shift4

Resolved

This incident has been resolved.
Posted Mar 23, 2025 - 11:17 PDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 23, 2025 - 11:16 PDT

Identified

We are currently experiencing an issue with our phone and chat systems, neither system is able to accept contacts at this time. In the interim, please contact us at shift4.com/support using our webform contacts.
Posted Mar 23, 2025 - 11:07 PDT
This incident affected: Third-Party Payments Provider or Vendor (Other).