Shift4Shop Email Delay
Incident Report for Shift4
Resolved
This incident has been resolved.
Posted Jan 06, 2024 - 08:31 PST
Identified
Our email vendor, SendGrid, has reported some technical issues affecting our email service. As a result, you may experience delays in email communications originating from the webserver. Please be assured that no emails will be lost during this time; they are being securely queued and will be delivered once the issue is resolved.
Posted Jan 05, 2024 - 08:18 PST
This incident affected: Shift4Shop (Support Systems).