Cash App credit card duplicate transactions

Incident Report for Shift4

Resolved

This incident has been resolved.
Posted Jun 28, 2023 - 06:34 PDT

Identified

Cash App credit card customers are seeing duplicate transactions.
Cash App has publicly acknowledged the issue.

Shift4 only sees one transaction, the issue is with Cash App which is owned by Square.

Please navigate to https://status.cash.app to monitor updates directly from Cash App.
Posted Jun 26, 2023 - 15:26 PDT
This incident affected: Payments Platform (Card Processing).