Phone system availability

Incident Report for Shift4

Resolved

This incident has been resolved.
Posted Apr 11, 2022 - 11:22 PDT

Investigating

Please be advised our phone system carrier is currently unable to field any phone calls, across all of our phone numbers. However, our chat system is available for use 24/7 across all of our primary websites for immediate help.

Our technical teams are engaged, and we will continue to keep you posted regarding our phone system. We apologize for the inconvenience.
Posted Apr 11, 2022 - 11:10 PDT