Intermittent time outs
Incident Report for Shift4 Payments
Resolved
We have resolved the issue
Posted May 26, 2021 - 16:27 UTC
Investigating
We are currently investigating this issue.
Posted May 26, 2021 - 16:10 UTC
This incident affected: Payments Platform (Card Processing).