Elavon Processing Issue
Incident Report for Shift4 Payments
Resolved
This incident has been resolved.
Posted May 20, 2021 - 00:29 UTC
Monitoring
We are seeing successful transaction processing with Elavon again and will continue to monitor for further issues this evening.
Posted May 20, 2021 - 00:12 UTC
Investigating
Elavon has a payment processing outage
Posted May 20, 2021 - 00:06 UTC
This incident affected: Third-Party Payments Provider or Vendor (Elavon).