Incident occurred
Incident Report for Shift4 Payments
Resolved
Incident resolved
Posted Apr 23, 2021 - 14:52 UTC
Monitoring
Incident occurred
Posted Apr 23, 2021 - 14:29 UTC
This incident affected: Third-Party Payments Provider or Vendor (First Data Rapid Connect).