Funding Delay
Incident Report for Shift4 Payments
Resolved
TSYS issue resolved. Funding is being worked for an afternoon release
Posted Jun 07, 2021 - 16:16 UTC
Update
We are talking with TSYS to understand what has happened on their end
Posted Jun 07, 2021 - 13:16 UTC
Investigating
We are currently investigating this issue and will update as soon as we have more information.
Posted Jun 07, 2021 - 12:37 UTC
This incident affected: Merchant Funding.