Incident occurred
Incident Report for Shift4 Payments
Resolved
Incident resolved
Posted Apr 26, 2021 - 17:32 UTC
Investigating
Incident occurred
Posted Apr 26, 2021 - 17:17 UTC
This incident affected: Payments Platform (Card Processing).