Shift4Shop forums offline
Incident Report for Shift4 Payments
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 10:05 PDT
Investigating
We apologize that the Shift4Shop forums are currently down.

We are working on getting them back up asap.
Posted Oct 04, 2021 - 05:56 PDT
This incident affected: Shift4Shop (Support Systems).