Shift4Shop UPS Rate Issue
Incident Report for Shift4 Payments
Resolved
This incident has been resolved.
Posted Oct 27, 2021 - 04:41 PDT
Identified
Issue has been identified and remediation is in progress. All other services are up and running.
Posted Oct 26, 2021 - 13:51 PDT
This incident affected: Shift4Shop (Online Stores).