Merchant Funding
Incident Report for Shift4 Payments
Resolved
We have confirmation that the batch in question will be made available before 3pm EST. We apologize for any inconvenience this may have caused you.
Posted Jul 15, 2021 - 15:51 UTC
Monitoring
Please be advised that some customers may experience funding delays of up to 24 business hours.
Unfortunately, this issue is due to reasons beyond our control. We sincerely apologize for the inconvenience.
Posted Jul 15, 2021 - 14:47 UTC
This incident affected: Merchant Funding.