Merchant Funding
Incident Report for Shift4 Payments
Resolved
Deposits for same day funding merchants should expect their deposits this afternoon.
Posted Aug 10, 2021 - 08:19 PDT
Monitoring
Please be advised that some customers may experience funding delays of up to 24 business hours.
Unfortunately, this issue is due to reasons beyond our control. We sincerely apologize for the inconvenience.
Posted Aug 10, 2021 - 05:57 PDT
This incident affected: Merchant Funding.