Merchant Funding
Incident Report for Shift4 Payments
Resolved
This incident has been resolved
Posted Aug 04, 2021 - 10:27 PDT
Monitoring
Please be advised that some customers may experience funding delays of up to 24 business hours.
Unfortunately, this issue is due to reasons beyond our control. We sincerely apologize for the inconvenience.
Posted Aug 04, 2021 - 05:17 PDT
This incident affected: Merchant Funding.