Credit Card Processing Issue
Incident Report for Shift4 Payments
Resolved
This incident has been resolved.
Posted Oct 28, 2021 - 12:47 PDT
Identified
We are experiencing an issue with card processing and are restoring services.
Posted Oct 28, 2021 - 12:41 PDT
This incident affected: Payments Platform (Card Processing).