Funding Delay
Incident Report for Shift4 Payments
Resolved
TSYS was delayed in submitting the file. It was received approximately 20 minutes later than the cut-off. Funds will be deposited this afternoon if they were expected this morning.
Posted May 27, 2021 - 12:50 UTC
Monitoring
We will update as soon as we know the timing for deposits.
Posted May 27, 2021 - 12:40 UTC
This incident affected: Merchant Funding.