Verizon mobile phone users cannot reach Shift4 Payments phone number 1.888.276.2108
Incident Report for Shift4 Payments
Resolved
Verizon has updated their configuration error and calling services are restored.
Posted Jun 24, 2021 - 08:30 PDT
Update
Please note the HT toll-free phone numbers are down for Verizon as well (1.800.632.1888 & 1.800.201.0461), please use the secondary phone for HT which is 610.596.4234
Posted Jun 24, 2021 - 06:09 PDT
Investigating
Please be advised that our main Shift4 Payments phone number 1.888.276.2108 is currently unable to accept calls from Verizon mobile phone numbers due to a technical service issue with Verizon.

In the interim, you can contact our secondary phone # at 702.597.2480 for assistance.
Posted Jun 24, 2021 - 06:00 PDT