Chat Support for Shift4Shop
Incident Report for Shift4 Payments
Resolved
This incident has been resolved.
Posted Jun 10, 2021 - 16:57 PDT
Identified
We apologize that our chat system is currently down. You can reach out to our support team by calling 1-800-828-6650 ext 6749 or emailing support@shift4shop.com
Posted Jun 10, 2021 - 16:03 PDT
This incident affected: Shift4Shop (Support Systems).